Auto-aiuto sui dispositivi personali

Attualmente il Servizio Calcolo del DMPA non è tenuto a fornire assistenza agli studenti che usano propri dispositivi. Prima di chiederci aiuto cercare di risolvere da sè il problema


Come installo i certificati del Dipartimento di Matematica?

Dovrebbe bastare l'installazione del certificato padre...

cd /etc/ssl/certs

wget --ca-certificate AddTrust_External_Root.pem 'terena...'

ln -s math.cacert.pem `openssl x509 -hash -noout -in terena...`.0

ln -s math.cacert.pem `openssl x509 -hash -noout -in math.cacert.pem`.0

e dovrebbe gia essere a posto:

openssl s_client -connect support.math.unipd.it:443 | less

To top


Ho problemi con il Wi-Fi!

Prima leggi le istruzioni per l'accesso WI-FI, relative al tuo sistema operativo. Dopo aver letto ed applicato (anche l'installzione del certificato):

Non trovo piu' l'access point della LuF-1

Perche' si e' passati da una frequenza di 2,4 GHz (b/g) a 5 GHz (a).

Controlla se la tua scheda di rete supporta il protocollo 802.11a (oltre al 802.11b/g ormai disponibile anche sugli smartphone).

Altrimente puoi scegliere tutte le altre reti rimanenti (ad esempio LuF2, LuM, P036, P140).

Non trovo piu' l'access point della LuF-2

Se la scheda del tuo portatile vede tutti gli access point Studenti.Math.UniPD.it (ad esempio LuF1, LuM, P036, P140) tranne quello della LuF2, il problema potrebbe essere dovuto al canale radio usato.

La LuF2 infatti e' stata settata sul canale 13 e questo canale potrebbe dare dei problemi con ad es. portatili acquistati in Usa, Canada, Francia o Giappone, o per altri motivi. Per risolvere questo problema bisogna abilitare nella vostra scheda l'uso del canale 13.

In Ubuntu potete installare il pacchetto iw con il comando:

sudo apt-get install
iw man iw                   #dalla schermata del manuale si esce con q

In generale con un sistema operativo Linux che fornisca il comando iw:

iw reg get ; iwlist channel #ho il canale 13?
iw reg set IT               #adesso si, spero
iw reg get ; iwlist channel #controllo

To top


Ho appena installato Ubuntu sul mio portatile. Che pacchetti potrei aggiungere?

Ubuntu Software Center - come esempio, stiamo cercando pacchetti di nome g++

Ubuntu è una distribuzione derivata da <a href="http://www.debian.org/">Debian</a>;  per fare esercizio va bene una qualsiasi distribuzione.

I comandi sotto (apt-get) sono tipici delle distribuzioni di tipo Debian e non di altre: ad esempio, non sono i comandi nativi per la gestione dei pacchetti di RedHat.

  1. Prima di tutto procedere con gli aggiornamenti: possono ad esempio essere necessari per far riconoscere la scheda Wi-Fi o altro hardware.
  2. Tanto per gli aggiornamenti che per l'installazione di nuovo software si può procedere sia usando l'interfaccia grafica che (in alternativa) la riga di comando; l'interfaccia grafica per gestire i pacchetti in Ubuntu si chiama "Ubuntu Software Center" e corrisponde all'eseguibile "software-center". Può essere immaginata l'omologo di Google Play per i dispositivi con Android, anche per la facilità di cercare ed installare il software. Nell'esempio a fianco volevamo installare il compilatore C++ ed abbiamo cercato il pacchett g++.
  3. da riga di comando gli aggiornamenti si fanno con:
 sudo su -
apt-get update
apt-get dist-upgrade
  1. ecco quindi i pacchetti che consigliamo di installare (nell'esempio installati da riga di comando)
 sudo su -
apt-get install --install-recommends emacs kate gobby jedit geany geany-plugins vim
apt-get install --install-recommends texlive lyx kile texmaker pdftk pdfjam psutils

apt-get install --install-recommends tcsh python3 python idle3 idle perl ruby
apt-get install --install-recommends eclipse gcc gdb qtcreator libqt4-designer chmsee cmake rapidsvn bzr git-all subversion subversion-tools bouml

apt-get install --install-recommends lynx links curl wget nvi filezilla putty clive vlc chromium-browser gimp scribus inkscape

apt-get install --install-recommends aptitude gdebi mc pv dzen2 md5deep dvdbackup alpine mutt

apt-get install --install-recommends gnome-session-fallback fvwm openbox fluxbox dwm
apt-get install --install-recommends grace dia xfig scidavis gnuplot octave3.2 qtoctave r-base

#: apt-get install --install-recommends pymol gromacs gausssum avogadro jmol


apt-get install --install-recommends extremetuxracer pingus frozen-bubble

aptitude remove postfix exim4

To top